$re = '/[a-z][a-z][^y ]/m';
$str = 'day dog hog hay bog bay ray rub';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);