using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"cat";
string input = @"The cat was cut when it ran under the car.";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}