package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)cat`)
var str = `The cat was cut when it ran under the car.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}