$re = '/\\\\[a-m]/m';
$str = '`\\n`, `\\r`, `\\t`, and `\\f` are whitespace characters, `\\.`, `\\\\` and `\\[` are not.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);