re = /\\[a-m]/m
str = '`\\n`, `\\r`, `\\t`, and `\\f` are whitespace characters, `\\.`, `\\\\` and `\\[` are not.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end