package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[a-zA-Z_$]\w\w`)
var str = `__e $12 .x2 foo Bar 3mm`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}