$re = '/[a-zA-Z_$]\w\w/m';
$str = '__e $12 .x2 foo Bar 3mm';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);