package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\d*\.\d+`)
var str = `0.011 .2 42 2.0 3.33 4.000 5 6 7.89012`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}