$re = '/\d*\.\d+/m';
$str = '0.011 .2 42 2.0 3.33 4.000 5 6 7.89012';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);