package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[a-z]+`)
var str = `3 plus 3 is six but 4 plus three is 7`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}