package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)dog|cat`)
var str = `Obviously, a dog is a better pet than a cat.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}