$re = '/dog|cat/m';
$str = 'Obviously, a dog is a better pet than a cat.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);