$re = '/(\w{4,})|(\w{1,3})/m';
$str = 'Kim Jobs Xu Cloyd Mohr Ngo Rock';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);