const regex = /\d{3}-\d{2}-\d{4}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\d{3}-\\d{2}-\\d{4}', 'gm')
const str = `113-25=1902 182-82-0192 H23-_3-9982 1I1-O0-E38B`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}