$re = '/\d{3}-\d{2}-\d{4}/m';
$str = '113-25=1902 182-82-0192 H23-_3-9982 1I1-O0-E38B';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);