$re = '/\([^()]{0,5}\)|\([^()]+\s[^()]*\)/m';
$str = '(12345) (my password) (Xanadu.2112) (su_do) (OfSalesmen!)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);