re = /\([^()]{0,5}\)|\([^()]+\s[^()]*\)/m
str = '(12345) (my password) (Xanadu.2112) (su_do) (OfSalesmen!)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end