package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\"\b[^"]{0,5}\b\"|\"\b[^"]+\s[^"]*\b\"`)
var str = `"thefollowingpasswordistooshort" "C++"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}