using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(^| )(\d+|\d+\.\d+)[KMGT]B";
string input = @"6.6KB 1..3KB 12KB 5G 3.3MB KB .6.2TB 9MB";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}