package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(^| )(\d+|\d+\.\d+)[KMGT]B`)
var str = `6.6KB 1..3KB 12KB 5G 3.3MB KB .6.2TB 9MB`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}