import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?=\\{Infobox)(\\{([^\\{\\}]|(?1))*\\})";
final String string = "{{Infobox xyz\n"
+ "|aaa= Xyz\n"
+ "|bbb= [[Xyz]]\n"
+ "|ccc=[[File:xyz.jpg|thumb|Xyz.]]\n"
+ "|ddd= {{lang|en|xyz}}\n"
+ "}}\n\n"
+ "[[File:abc.jpg|thumb|Abc.]]";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}