$re = '/(?=\{Infobox)(\{([^{}]|(?1))*\})/m';
$str = '{{Infobox xyz
|aaa= Xyz
|bbb= [[Xyz]]
|ccc=[[File:xyz.jpg|thumb|Xyz.]]
|ddd= {{lang|en|xyz}}
}}
[[File:abc.jpg|thumb|Abc.]]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);