re = /Empfänger\s+(.*)/m
str = 'Empfänger Max Mustermann
99999 Musterstadt * Musterstraße 5
Lieferavis max.muster@mustermail.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end