use strict;
my $str = 'Ladeliste: speditions
logistics
GmbH
-
D-9999 Speditionsstadt
Seite 1
Kunde:
Chrsitkind SE (#41155~42784)
16.10.2019 11:20
Sendungs-Nr: 0002011147
Auftrags-Nr: 11161
Frankatur: frei Haus
Depot: 007
Auftraggeber Christkind-
*
(#41155~42784)
9999 Wunderstandt
*
Wunderstraße 001
Empfänger Max Muster TEST
99992 Musterstadt
*
Musterstraße
1
Lieferavis
mustermannmax@gmx.de
Ladezeit
17.10.19
Termin
B2CLine
Hinweis-Schl: nur mit Hebebühne zustellen
Avis Festnetz: 0177007007007 / 000 32586914
S-Zeilen:
1 EE
Saunaaufguss
315
kg 120x080x120 1,152cbm
Calnids
100 340294943036198282
DRAN 000 TTAN
**
1
Sdg., 1 Colli (1 EE), gesamt 315 kg.';
my $regex = qr/(?i)(?<=Empfänger)([\s]*)\b([\S\t ]*)\b/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";