package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\h*[a-zA-Z0-9_-]+\h*=>\h*[a-zA-Z0-9_-]+\h*$`)
var str = `Field=>Value-True
Field => Value-True
=>False_name
Bad_name_2=>
=>
=>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}