import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\h*[a-zA-Z0-9_-]+\\h*=>\\h*[a-zA-Z0-9_-]+\\h*$";
final String string = "Field=>Value-True\n"
+ " Field => Value-True \n"
+ " =>False_name\n"
+ "Bad_name_2=>\n"
+ " => \n"
+ "=>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}