#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?x)# Anchor the pattern so we do the duplicate scan only once" & @CRLF & _
"\A" & @CRLF & _
"" & @CRLF & _
"# For each letter, test to see if it's duplicated in the input string" & @CRLF & _
"(?(?=[^a]*+a[^a]*a)(?<da>))" & @CRLF & _
"(?(?=[^b]*+b[^b]*b)(?<db>))" & @CRLF & _
"(?(?=[^c]*+c[^c]*c)(?<dc>))" & @CRLF & _
"(?(?=[^d]*+d[^d]*d)(?<dd>))" & @CRLF & _
"(?(?=[^e]*+e[^e]*e)(?<de>))" & @CRLF & _
"(?(?=[^f]*+f[^f]*f)(?<df>))" & @CRLF & _
"(?(?=[^g]*+g[^g]*g)(?<dg>))" & @CRLF & _
"(?(?=[^h]*+h[^h]*h)(?<dh>))" & @CRLF & _
"(?(?=[^i]*+i[^i]*i)(?<di>))" & @CRLF & _
"(?(?=[^j]*+j[^j]*j)(?<dj>))" & @CRLF & _
"(?(?=[^k]*+k[^k]*k)(?<dk>))" & @CRLF & _
"(?(?=[^l]*+l[^l]*l)(?<dl>))" & @CRLF & _
"(?(?=[^m]*+m[^m]*m)(?<dm>))" & @CRLF & _
"(?(?=[^n]*+n[^n]*n)(?<dn>))" & @CRLF & _
"(?(?=[^o]*+o[^o]*o)(?<do>))" & @CRLF & _
"(?(?=[^p]*+p[^p]*p)(?<dp>))" & @CRLF & _
"(?(?=[^q]*+q[^q]*q)(?<dq>))" & @CRLF & _
"(?(?=[^r]*+r[^r]*r)(?<dr>))" & @CRLF & _
"(?(?=[^s]*+s[^s]*s)(?<ds>))" & @CRLF & _
"(?(?=[^t]*+t[^t]*t)(?<dt>))" & @CRLF & _
"(?(?=[^u]*+u[^u]*u)(?<du>))" & @CRLF & _
"(?(?=[^v]*+v[^v]*v)(?<dv>))" & @CRLF & _
"(?(?=[^w]*+w[^w]*w)(?<dw>))" & @CRLF & _
"(?(?=[^x]*+x[^x]*x)(?<dx>))" & @CRLF & _
"(?(?=[^y]*+y[^y]*y)(?<dy>))" & @CRLF & _
"(?(?=[^z]*+z[^z]*z)(?<dz>))" & @CRLF & _
"" & @CRLF & _
"# Skip any duplicated letter and throw it away" & @CRLF & _
"[a-z]*?\K" & @CRLF & _
"" & @CRLF & _
"# Check if the next letter is a duplicate" & @CRLF & _
"(?:" & @CRLF & _
" a (*THEN) (?(da)(*FAIL))" & @CRLF & _
"| b (*THEN) (?(db)(*FAIL))" & @CRLF & _
"| c (*THEN) (?(dc)(*FAIL))" & @CRLF & _
"| d (*THEN) (?(dd)(*FAIL))" & @CRLF & _
"| e (*THEN) (?(de)(*FAIL))" & @CRLF & _
"| f (*THEN) (?(df)(*FAIL))" & @CRLF & _
"| g (*THEN) (?(dg)(*FAIL))" & @CRLF & _
"| h (*THEN) (?(dh)(*FAIL))" & @CRLF & _
"| i (*THEN) (?(di)(*FAIL))" & @CRLF & _
"| j (*THEN) (?(dj)(*FAIL))" & @CRLF & _
"| k (*THEN) (?(dk)(*FAIL))" & @CRLF & _
"| l (*THEN) (?(dl)(*FAIL))" & @CRLF & _
"| m (*THEN) (?(dm)(*FAIL))" & @CRLF & _
"| n (*THEN) (?(dn)(*FAIL))" & @CRLF & _
"| o (*THEN) (?(do)(*FAIL))" & @CRLF & _
"| p (*THEN) (?(dp)(*FAIL))" & @CRLF & _
"| q (*THEN) (?(dq)(*FAIL))" & @CRLF & _
"| r (*THEN) (?(dr)(*FAIL))" & @CRLF & _
"| s (*THEN) (?(ds)(*FAIL))" & @CRLF & _
"| t (*THEN) (?(dt)(*FAIL))" & @CRLF & _
"| u (*THEN) (?(du)(*FAIL))" & @CRLF & _
"| v (*THEN) (?(dv)(*FAIL))" & @CRLF & _
"| w (*THEN) (?(dw)(*FAIL))" & @CRLF & _
"| x (*THEN) (?(dx)(*FAIL))" & @CRLF & _
"| y (*THEN) (?(dy)(*FAIL))" & @CRLF & _
"| z (*THEN) (?(dz)(*FAIL))" & @CRLF & _
")" & @CRLF & _
""
Local $sString = "hahxyza"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")