import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "# Anchor the pattern so we do the duplicate scan only once\n"
+ "\\A\n\n"
+ "# For each letter, test to see if it's duplicated in the input string\n"
+ "(?(?=[^a]*+a[^a]*a)(?<da>))\n"
+ "(?(?=[^b]*+b[^b]*b)(?<db>))\n"
+ "(?(?=[^c]*+c[^c]*c)(?<dc>))\n"
+ "(?(?=[^d]*+d[^d]*d)(?<dd>))\n"
+ "(?(?=[^e]*+e[^e]*e)(?<de>))\n"
+ "(?(?=[^f]*+f[^f]*f)(?<df>))\n"
+ "(?(?=[^g]*+g[^g]*g)(?<dg>))\n"
+ "(?(?=[^h]*+h[^h]*h)(?<dh>))\n"
+ "(?(?=[^i]*+i[^i]*i)(?<di>))\n"
+ "(?(?=[^j]*+j[^j]*j)(?<dj>))\n"
+ "(?(?=[^k]*+k[^k]*k)(?<dk>))\n"
+ "(?(?=[^l]*+l[^l]*l)(?<dl>))\n"
+ "(?(?=[^m]*+m[^m]*m)(?<dm>))\n"
+ "(?(?=[^n]*+n[^n]*n)(?<dn>))\n"
+ "(?(?=[^o]*+o[^o]*o)(?<do>))\n"
+ "(?(?=[^p]*+p[^p]*p)(?<dp>))\n"
+ "(?(?=[^q]*+q[^q]*q)(?<dq>))\n"
+ "(?(?=[^r]*+r[^r]*r)(?<dr>))\n"
+ "(?(?=[^s]*+s[^s]*s)(?<ds>))\n"
+ "(?(?=[^t]*+t[^t]*t)(?<dt>))\n"
+ "(?(?=[^u]*+u[^u]*u)(?<du>))\n"
+ "(?(?=[^v]*+v[^v]*v)(?<dv>))\n"
+ "(?(?=[^w]*+w[^w]*w)(?<dw>))\n"
+ "(?(?=[^x]*+x[^x]*x)(?<dx>))\n"
+ "(?(?=[^y]*+y[^y]*y)(?<dy>))\n"
+ "(?(?=[^z]*+z[^z]*z)(?<dz>))\n\n"
+ "# Skip any duplicated letter and throw it away\n"
+ "[a-z]*?\\K\n\n"
+ "# Check if the next letter is a duplicate\n"
+ "(?:\n"
+ " a (*THEN) (?(da)(*FAIL))\n"
+ "| b (*THEN) (?(db)(*FAIL))\n"
+ "| c (*THEN) (?(dc)(*FAIL))\n"
+ "| d (*THEN) (?(dd)(*FAIL))\n"
+ "| e (*THEN) (?(de)(*FAIL))\n"
+ "| f (*THEN) (?(df)(*FAIL))\n"
+ "| g (*THEN) (?(dg)(*FAIL))\n"
+ "| h (*THEN) (?(dh)(*FAIL))\n"
+ "| i (*THEN) (?(di)(*FAIL))\n"
+ "| j (*THEN) (?(dj)(*FAIL))\n"
+ "| k (*THEN) (?(dk)(*FAIL))\n"
+ "| l (*THEN) (?(dl)(*FAIL))\n"
+ "| m (*THEN) (?(dm)(*FAIL))\n"
+ "| n (*THEN) (?(dn)(*FAIL))\n"
+ "| o (*THEN) (?(do)(*FAIL))\n"
+ "| p (*THEN) (?(dp)(*FAIL))\n"
+ "| q (*THEN) (?(dq)(*FAIL))\n"
+ "| r (*THEN) (?(dr)(*FAIL))\n"
+ "| s (*THEN) (?(ds)(*FAIL))\n"
+ "| t (*THEN) (?(dt)(*FAIL))\n"
+ "| u (*THEN) (?(du)(*FAIL))\n"
+ "| v (*THEN) (?(dv)(*FAIL))\n"
+ "| w (*THEN) (?(dw)(*FAIL))\n"
+ "| x (*THEN) (?(dx)(*FAIL))\n"
+ "| y (*THEN) (?(dy)(*FAIL))\n"
+ "| z (*THEN) (?(dz)(*FAIL))\n"
+ ")\n";
final String string = "hahxyza";
final Pattern pattern = Pattern.compile(regex, Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}