use strict;
my $str = 'Saya akan menyambutnya di kampung. Kita saling menyayangi untuk minum air teh. menganggap menggertak minggu mencinta
pandai
air
aila';
my $regex = qr/(?:kh|n[yg]|sy|[bcdfghjklmnpqrstvwxyz])*(?:a(?:[iu](?!(?:kh|n[yg]|sy|[bcdfghjklmnpqrstvwxyz])+\b))?|o(?:i(?!(?:kh|n[yg]|sy|[bcdfghjklmnpqrstvwxyz])+\b))?|[aeiou])(?:(?:kh|n[yg]|sy|[bcdfghjklmnpqrstvwxyz])*(?=[^a-zA-Z]|$)|(?=(kh|n[yg]|sy|[bcdfghjklmnpqrstvwxyz]))\1(?=kh|n[yg]|sy|[bcdfghjklmnpqrstvwxyz]))?/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}