import Foundation
let pattern = #"(?:kh|n[yg]|sy|[bcdfghjklmnpqrstvwxyz])*(?:a(?:[iu](?!(?:kh|n[yg]|sy|[bcdfghjklmnpqrstvwxyz])+\b))?|o(?:i(?!(?:kh|n[yg]|sy|[bcdfghjklmnpqrstvwxyz])+\b))?|[aeiou])(?:(?:kh|n[yg]|sy|[bcdfghjklmnpqrstvwxyz])*(?=[^a-zA-Z]|$)|(?=(kh|n[yg]|sy|[bcdfghjklmnpqrstvwxyz]))\1(?=kh|n[yg]|sy|[bcdfghjklmnpqrstvwxyz]))?"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
Saya akan menyambutnya di kampung. Kita saling menyayangi untuk minum air teh. menganggap menggertak minggu mencinta
pandai
air
aila
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)