package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b(n\w*t)(\d+)\b|(\S+)`)
var str = `payment term nt40 net00 net30`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}