$re = '/\b(n\w*t)(\d+)\b|(\S+)/m';
$str = 'payment term nt40 net00 net30';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);