package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[^0-9.-]`)
var str = `123test
123-secon.dtest
0815bla
-154689-
345
---`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}