$re = '/[^0-9.-]/m';
$str = '123test
123-secon.dtest
0815bla
-154689-
345
---';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);