const regex = /.*(INC\d{4,8})|(\d{5,8}).*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.*(INC\\d{4,8})|(\\d{5,8}).*', 'gm')
const str = `INC4312 9/4/2022
12345
1234
9/4/2022`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}