using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\((.*?)\)\sstarted playing\s(.*?)(?: - (.*?))?\.
";
string input = @"hyper_d (Galaxy S9) started playing King of the Hill - Episode 419.
hyper_d (Galaxy S9) started playing Trolls Band Together.";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}