import re
regex = re.compile((r"\((.*?)\)\sstarted playing\s(.*?)(?: - (.*?))?\.\n"), flags=re.MULTILINE)
test_str = ("hyper_d (Galaxy S9) started playing King of the Hill - Episode 419.\n\n"
"hyper_d (Galaxy S9) started playing Trolls Band Together.")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")