import re
regex = re.compile(r"(<p id=\"nav\">)\s?(.*?)\s?(<\/p>)")
test_str = ("<p id=\"nav\">\n"
"<a href=\"http://tenupclp.dev/wp-login.php?action=register\">Register</a> | <a href=\"http://tenupclp.dev/wp-login.php?action=lostpassword\">Lost your password?</a>\n"
"</p>")
subst = "$1fart$3"
result = regex.sub(subst, test_str)
if result:
print(result)