#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?ims)LLPart1:(.*?)LLPart2"
Local $sString = "BundleFormat: 1" & @CRLF & _
"Name: TestIllegalStringsLintalist" & @CRLF & _
"Description: Created just to see what strings Lintalist uses" & @CRLF & _
"Author: Gurlan Vasile" & @CRLF & _
"TitleMatch: .txt" & @CRLF & _
"Patterns:" & @CRLF & _
"- LLPart1: [[Calendar=]]" & @CRLF & _
" LLPart2: >>date" & @CRLF & _
" LLKey: " & @CRLF & _
" LLShorthand: >>calendar" & @CRLF & _
" LLScript: " & @CRLF & _
"- LLPart1: Syntax:" & @CRLF & _
"__multilinevar --> create multiline variable" & @CRLF & _
"" & @CRLF & _
"Notepad++:" & @CRLF & _
"__lngAuto --> Notepad++ : change language to Autohotkey" & @CRLF & _
"" & @CRLF & _
"AHK Studio:" & @CRLF & _
"__refresh --> AHK Studio : refresh project" & @CRLF & _
"" & @CRLF & _
"Other:" & @CRLF & _
"__tgs --> any editor : paste tags template" & @CRLF & _
"__newcode --> any editor : create code for Lintalist to be displayed properly" & @CRLF & _
"__lintalist --> any editor : create code for Lintalist to be displayed properly" & @CRLF & _
" LLPart2: " & @CRLF & _
" LLKey: " & @CRLF & _
" LLShorthand: >>>?" & @CRLF & _
" LLScript: " & @CRLF & _
"- LLPart1: messagebox show" & @CRLF & _
" LLPart2: " & @CRLF & _
" LLKey: " & @CRLF & _
" LLShorthand: " & @CRLF & _
" LLScript: MsgBox, Test" & @CRLF & _
"- LLPart1: wfaw" & @CRLF & _
" LLPart2: fwa" & @CRLF & _
" LLKey: " & @CRLF & _
" LLShorthand: " & @CRLF & _
" LLScript: " & @CRLF & _
"- LLPart1: some code here" & @CRLF & _
" LLPart2: some descriptive text here" & @CRLF & _
" LLKey: " & @CRLF & _
" LLShorthand: smcd" & @CRLF & _
" LLScript: msgbox, HelloWorld" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")