$re = '/[A-Za-z]\d+/m';
$str = 'Cuvânt m746463 cheie pentru NLC furnizat';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);