$re = '/<span\s*style="(.*)"\s*>(?<content>.*?)<\/span>/';
$str = '<div class="recent-ticket">
<div class="truncate">#115904 - تست</div><small><span class="pull-right">1 day ago</span><span style="color:#ff6600">پاسخ مشتری</span></small></div><div class="recent-ticket">
<div class="truncate">#962777 - تست اسکرول ناحیه کاربری</div><small><span class="pull-right">1 day ago</span><span style="color:#779500">در انتظار پاسخ</span></small></div><div class="recent-ticket">
<div class="truncate">#411127 - تست موارد</div><small><span class="pull-right">1 day ago</span><span style="color:#779500">در انتظار پاسخ</span></small></div><div class="recent-ticket">
<div class="truncate">#967913 - تست استایل</div><small><span class="pull-right">2 weeks ago</span><span style="color:#888888">بسته شده</span></small>
</div>
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);