use strict;
my $str = '11 91129-1231
11 91231-2343 11 2322-4332
15 98221-9540 12 93853-2343 45 4332-0593';
my $regex = qr/^[1-9]{2} (?:[2-8]|9[1-9])[0-9]{3}\-[0-9]{4}( [1-9]{2} (?:[2-8]|9[1-9])[0-9]{3}\-[0-9]{4})*$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}