import re
regex = re.compile(r"^[1-9]{2} (?:[2-8]|9[1-9])[0-9]{3}\-[0-9]{4}( [1-9]{2} (?:[2-8]|9[1-9])[0-9]{3}\-[0-9]{4})*$", flags=re.MULTILINE)
test_str = ("11 91129-1231\n"
"11 91231-2343 11 2322-4332\n"
"15 98221-9540 12 93853-2343 45 4332-0593")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")