# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"BEGIN:VEVENT DTEND;VALUE=DATE:(.*?) DTSTART;VALUE=DATE: (.*?) UID:(.*?) SUMMARY:(.*?) END:VEVENT"
test_str = "BEGIN:VCALENDAR PRODID;X-RICAL-TZSOURCE=TZINFO:-//Airbnb Inc//Hosting Calendar 0.8.8//EN CALSCALE:GREGORIAN VERSION:2.0 BEGIN:VEVENT DTEND;VALUE=DATE:20221105 DTSTART;VALUE=DATE: 20220831 UID:6fec1092d3fa-a701f68d2829d331bc90b193830d447d@airbnb.com SUMMARY:Airbnb (Not available) END:VEVENT BEGIN:VEVENT DTEND;VALUE=DATE:20230103 DTSTART;VALUE=DATE:20221227 UID:6fec1092d3fa-e3596dc423d3ebfc6717c45d59f237ec@airbnb.com SUMMARY:Airbnb ( Not available) END:VEVENT BEGIN:VEVENT DTEND;VALUE=DATE:20230311 DTSTART;VALUE=DATE:20230212 UID:6fec1092d3fa-db18d3df7f07179688122eb867e2e274@airbnb.com SUMMARY:Airbnb (Not available) END:VEVENTDATE BEGIN:VEVENT= DTEND :20230903 DTSTART;VALUE=DATE:20230701 UID:6fec1092d3fa-de03b88cfd4d214ed4890da8da3a3541@airbnb.com SUMMARY:Airbnb (Not available) END:VEVENT END:VCALENDAR"
matches = re.finditer(regex, test_str, re.MULTILINE | re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.