package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[force]at`)
var str = `A fat cat doesn't eat oat but a rat eats bats.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}