package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\bself\._\w*|(\w+\.\_\w+)`)
var str = `object._attr self._attr object._attr
a._aaa
self._attr
object._`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}