// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\bself\._\w*|(\w+\.\_\w+)").unwrap();
let string = "object._attr self._attr object._attr
a._aaa
self._attr
object._";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}