package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([+-]?\d+)(\.\d+)?$`)
var str = `29989773.23
29989773.2.33
299897.7377`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}