# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\w=)\(([^()|]+(?:\|[^()|]+)+)\)/$1$2/gm;t' <<< "(x=(1.22|2|3) && za=(hello|world|there|wow)||yy=(2|3))"