$re = '/(\w=)\(([^()|]+(?:\|[^()|]+)+)\)/m';
$str = '(x=(1.22|2|3) && za=(hello|world|there|wow)||yy=(2|3))';
$subst = "$1$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;